Association du Grand Avignon des utilisateurs de Linux / *BSD, et de logiciels libres.

mardi 12 avril 2016

Quelques infos concernant le développement de la Linux Mint 18 au cours du mois de mars 2016

Voici, un résumé (avec surtout des compléments d'information) sur le billet du mois de mars 2016 à propos de la prochaine Linux Mint 18.

Une traduction complète (mot à mot) est disponible sur le forum LinuxMint-fr.

Lire la suite...

samedi 6 février 2016

Quelques infos sur la prochaine Linux Mint 18

À la lecture du dernier billet concernant Linux Mint, on apprend que les développeurs sont déjà en train de « plancher » sur la prochaine Linux Mint 18 (nom de code Sarah) [1].

Elle sera basée sur la Ubuntu 16.04 (alias Xenial Xerus). De nombreuses bibliothèques seront mises à jour, notamment GTK+. On va passer d'une version 3.10.x vers 3.18.x. De nouveaux widgets ont été introduit en particulier :

  • GtkHeaderBar
  • GtkActionBar
  • GtkPopover
  • GtkActionBar

D'autres sont obsolètes par conséquent les thèmes pour les bureaux MATE, Xfce et Cinnamon doivent être entièrement revus. C'est pourquoi une attention toute particulière est portée sur un nouveau thème (dans un soucis de rendre les différentes applications uniforme les unes par rapport aux autres).

De plus, Linux Mint embarque actuellement de nombreuses applications en provenance du bureau GNOME, et comme ces dernières dépendent étroitement des nouvelles fonctionnalités introduites dans GTK+ et GNOME Shell, un nouveau projet a été initié, il s'appelle X-Apps. Le but étant d'utiliser pour les besoins courants des applications desktop-agnostic.

[...] For the most part, these desktops present similar needs so it made sense to maintain one generic set of apps which can be used in all of them, and to do so outside of the scope of any of these desktops.

The core ideas for X-Apps are:

* To use GTK3

* To use a traditional UI (titlebars, menubars)

* To be generic, desktop-agnostic and distro-agnostic

* To provide the functionality users already enjoy (or enjoyed in the past for distributions which already lost some functionality)

* To be backward-compatible (hopefully all the way to GTK 3.10)

Les développeurs ne partent pas de zéro, mais se basent sur des applications déjà existantes. Par exemple on peut citer XPlayer basé sur Totem 3.10, ou Xed basé sur Gedit et Pluma.

On voit que le chemin est encore long pour la prochaine sortie, prévue pour mai (voir juin) 2016.

Note

[1] Pour en savoir plus, je vous conseille de lire ce post (en anglais).

dimanche 10 janvier 2016

Linux Mint 17.3 "Rosa" est sortie

Ce 9 janvier 2015, l'équipe en charge du développement de Linux Mint vient de publier une nouvelle version de la série 17.x.

Elle est supportée jusqu'en 2019.

Lire la suite...

lundi 22 décembre 2014

Upgrade sans filet !

logo openSUSE

Dans ce billet, je vais vous expliquer la procédure, que j'ai suivi pour mettre à jour (rapidement, et donc sans sauvegarde) mon système Linux (openSUSE).

Ceci a été décidé sur un coup de tête. Après un n-ième ras-le-bol suite à une mise à jour de sécurité, m'obligeant à démarrer uniquement en mode « dégradé » [1].

Note

[1] La mise à jour de sécurité n'a pourtant pas impacté la gestion de la carte graphique.

Lire la suite...

dimanche 30 novembre 2014

Linux Mint 17.1, Rebecca

Linux Mint 17.1 "Rebecca" vient d'être annoncé (le 29 novembre 2014) par Clement Lefebvre. Cette mise à jour de la série 17, se focalise essentiellement sur les environnements de bureaux, Mate Desktop, et Cinnamon.

Toutes les versions de la série 17 sont dites LTS, les mises à jours de sécurité seront donc supportées jusqu'en 2019. De plus, la base est toujours Ubuntu14.04.

Linux Mint, MATE edition

Cette version supporte nativement deux gestionnaires de fenêtres, marco (le window manager du bureau Mate) et compiz (il repose sur OpenGL, nécessite l'activation du support 3D de la carte graphique).

Pour plus de détails, vous pouvez consulter cette page.

Linux Mint, Cinnamon edition

Elle embarque la dernière version (2.4) de ce bureau. Cinnamon nécessite le support de l'accélération 3D de la carte graphique (notamment pour un meilleur rendu avec clutter). Cependant cette caractéristique peut être désactivée (dans les préférences du bureau).

Pour plus de détails, vous pouvez consulter cette page.

Pour mettre à jour, pour ceux utilisant déjà la distribution dans la version 17, il faut appliquer les mises à jour de niveau 1 dans le Gestionnaire de Mises à Jour.

jeudi 14 février 2013

Configurer gnome 3 pour le rendre plus sympa :

Réduire la taille des icones.
Rétablir les boutons comme sous gnome2
Rajouter des extensions

Lire la suite...

vendredi 11 mai 2012

NAS illimite avec windav et hubic

Merci a Kuri sur le site https://paranoia.abuser.eu/wordpress/?p=30

Mon NAS illimite.

Lire la suite...

jeudi 5 janvier 2012

Résolution du problème connexion ethernet filaire ASUS Eee PC 1005PXD Athéros AR 8152 Ubuntu 10.04 LTS

Afin de rendre effective la connexion de la carte réseau ethernet Athéros AR 8152 sous Ubuntu 10.04 LTS, il faut faire un upgrade du noyau 2.6.x-x à la version 3.0.0-14 dans le gestionnaire de paquets Synaptic.

  1. aller dans Synaptic (Système-> Administration) ;
  2. rechercher "linux-image-3.0.0-14-generic" ;
  3. cocher et choisir pour installation cette version du noyau ;
  4. appliquer les changements ;
  5. et redémarrer.

Enjoy ! ;-)

samedi 10 décembre 2011

Installer ALSA sous Frugalware PowerPC

Frugalware

Ce billet est la suite du précédent. Nous allons voir comment installer ALSA.

Il s'agit d'un iBook G4, (le modèle n'est pas récent).

olivierd@brigand:~ $ cat /proc/device-tree/model && echo ""
PowerBook6,5
olivierd@brigand:~ $ 

Installation du paquet

root@brigand:~ # pacman-g2 -S alsa-utils alsa-tools
[...]
root@brigand:~ # 

Configuration

Nous pouvons lancer la commande alsaconf, il va rechercher le driver correspondant à notre carte audio.

Dans mon cas il n'arrive pas à la détecter.

root@brigand:~ # cat /proc/asound/cards
 --- no soundcards ---
root@brigand:~ # 

Nous allons donc rechercher tous les modules installés sur la machine.

root@brigand:~ # find / -type f -name '*.ko' -print
[...]
/lib/modules/3.1-fw2/kernel/sound/usb/snd-usb-audio.ko
/lib/modules/3.1-fw2/kernel/sound/usb/snd-usbmidi-lib.ko
/lib/modules/3.1-fw2/kernel/sound/ppc/snd-powermac.ko
/lib/modules/3.1-fw2/kernel/sound/drivers/snd-dummy.ko
/lib/modules/3.1-fw2/kernel/sound/aoa/codecs/snd-aoa-codec-toonie.ko
/lib/modules/3.1-fw2/kernel/sound/aoa/codecs/snd-aoa-codec-tas.ko
/lib/modules/3.1-fw2/kernel/sound/aoa/codecs/snd-aoa-codec-onyx.ko
/lib/modules/3.1-fw2/kernel/sound/aoa/fabrics/snd-aoa-fabric-layout.ko
/lib/modules/3.1-fw2/kernel/sound/aoa/soundbus/i2sbus/snd-aoa-i2sbus.ko
/lib/modules/3.1-fw2/kernel/sound/aoa/soundbus/snd-aoa-soundbus.ko
/lib/modules/3.1-fw2/kernel/sound/aoa/core/snd-aoa.ko
/lib/modules/3.1-fw2/kernel/sound/core/seq/snd-seq-device.ko
/lib/modules/3.1-fw2/kernel/sound/core/seq/snd-seq.ko
/lib/modules/3.1-fw2/kernel/sound/core/seq/snd-seq-midi-event.ko
/lib/modules/3.1-fw2/kernel/sound/core/seq/oss/snd-seq-oss.ko
/lib/modules/3.1-fw2/kernel/sound/core/seq/snd-seq-dummy.ko
/lib/modules/3.1-fw2/kernel/sound/core/seq/snd-seq-midi.ko
/lib/modules/3.1-fw2/kernel/sound/core/snd-hwdep.ko
/lib/modules/3.1-fw2/kernel/sound/core/oss/snd-mixer-oss.ko
/lib/modules/3.1-fw2/kernel/sound/core/oss/snd-pcm-oss.ko
/lib/modules/3.1-fw2/kernel/sound/core/snd-rawmidi.ko
/lib/modules/3.1-fw2/kernel/sound/core/snd-pcm.ko
/lib/modules/3.1-fw2/kernel/sound/core/snd-page-alloc.ko
/lib/modules/3.1-fw2/kernel/sound/core/snd.ko
/lib/modules/3.1-fw2/kernel/sound/core/snd-timer.ko
/lib/modules/3.1-fw2/kernel/sound/soundcore.ko

Il faut donc rechercher le bon module dans le dossier /lib/modules/3.1-fw2/kernel/sound/. Un seul va retenir mon intention, snd-powermac.ko. Je vais le charger.

root@brigand:~ # modprobe snd_powermac
root@brigand:~ # cat /proc/asound/cards
 0 [Snapper        ]: PMac Snapper - PowerMac Snapper
                      PowerMac Snapper (Dev 44) Sub-frame 0
root@brigand:~ # 

C'est effectivement le bon [1].

Maintenant, nous pouvons régler le volume avec alsamixer, et sauvegarder cette configuration avec la commande suivante :

root@brigand:~ # alsactl store

ALSA et Systemd ?

Depuis que Frugalware utilise Systemd, les modules additionnels qui doivent être chargés au démarrage, doivent être « listés » dans le dossier /etc/modules-load.d/.

J'ai donc créé le fichier sound.conf :

# Load snd-powermac.ko at boot
snd-powermac

Note

[1] Je vous recommande de lire ces pages Gentoo PPC Faq, et Apple Onboard Audio.

mercredi 30 novembre 2011

Installation (manuelle) d'une Frugalware PowerPC

Frugalware

Dans ce billet, je vais relater les différentes étapes pour installer la Frugalware (l'installateur est bugué, segfault aléatoirement) sur un ordinateur dont le processeur, est de type PowerPC. Il s'agit d'un iBook G4.

olivierd@brigand:~ $ cat /proc/cpuinfo 
processor       : 0
cpu             : 7447A, altivec supported
clock           : 1333.333000MHz
revision        : 1.2 (pvr 8003 0102)
bogomips        : 73.72
timebase        : 18432000
platform        : PowerMac
model           : PowerBook6,5
machine         : PowerBook6,5
motherboard     : PowerBook6,5 MacRISC3 Power Macintosh 
detected as     : 287 (iBook G4)
pmac flags      : 0000001b
L2 cache        : 512K unified
pmac-generation : NewWorld
Memory          : 1280 MB
olivierd@brigand:~ $ 

Lire la suite...

- page 1 de 2