Dimanche 15 août 2021

Mise à jour vers la version 2.19

Une petite frayeur chez notre hébergeur, après avoir effectué la mise à jour vers la version 2.19. On avait uniquement une page blanche (que se soit la partie publique ou privée).

Comme on a un accès par SSH, je regarde les différentes versions de PHP, [1] on a :

  • php5.6 -> PHP 5.6.40-27+01.gbp02e670
  • php7.3 -> PHP 7.3.27-1~deb10u1
  • php lien symbolique vers la version ci-dessus

En parcourant la FAQ, je tombe sur une entrée, expliquant comment utiliser la version PHP7 [2]

Il faut rajouter cette ligne (à placer dans un fichier .htaccess)

AddType application/x-httpd-php7 .php

Le miracle ! Tout est revenu à la normale. Je trouve que le temps de chargement des pages est un peu plus long (c'est subjectif).

Notes

[1] Car d'après le ChangeLog, la version minimale est la 7.3

[2] Au départ, j'étais dubitatif, car l'utilitaire php pointe directement vers la version 7.

mardi 5 septembre 2017

HTTPS partout

L'ensemble des sites (blog et wiki) sont désormais uniquement accessibles en HTTPS [1]. Merci à notre hébergeur TuxFamily pour cette initiative.

L'ajout d'un fichier .htaccess à la racine avec ce contenu permet de mettre en place cette fonctionnalité :

RewriteEngine On
RewriteCond %{HTTPS} off
RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI} [L]

Note

[1] Cela fait suite à une demande de plusieurs adhérents sur notre liste de diffusion.

mardi 20 janvier 2015

Quelques informations intéressantes concernant Linux Mint Debian Edition (LMDE)

On en apprend un peu plus sur la prochaine Linux Mint Debian Edition (LMDE), dont le nom de code est Betsy, si l'on en croit le dernier rapport publié par l'équipe dirigeante du projet.

Elle sera basée sur Debian 8.0, Jessie. Elle incorporera les derniers logiciels que l'on retrouve dans les Ubuntu editions. Notamment la dernière version de Cinnamon 2.4, MATE côté gestionnaire de bureaux.

Un autre point important, le système d'init sera toujours system v [1] au lieu du controversé systemd (Cinnamon 2.4 ne supporte pas encore systemd, c'est planifié pour la prochaine version stable). Ils (les développeurs de Linux Mint) préfère attendre que ce dernier soit assez mature dans Debian, donc pas avant deux ans (voir plus).

Note

[1] Contrairement à celui prévu dans Debian Jessie.